What’s Vulnerable › Vulnerabilities
CVE-2023-41419
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-25 · updated 2026-06-17
Description
An issue in Gevent before version 23.9.0 allows a remote attacker to escalate privileges via a crafted script to the WSGIServer component.
Affected products
- Gevent: before 23.9.0 — fixed in 23.9.0
How to fix
Upgrade to a fixed version: Gevent 23.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/gevent/gevent/commit/2f53c851eaf926767fbac62385615efd4886221c
- https://github.com/gevent/gevent/issues/1989
- https://github.com/gevent/gevent/commit/2f53c851eaf926767fbac62385615efd4886221c
- https://github.com/gevent/gevent/issues/1989
- https://lists.debian.org/debian-lts-announce/2025/11/msg00020.html
Get alerted when CVE-2023-41419 or the next vulnerability affects your stack