What’s Vulnerable › Vulnerabilities
CVE-2023-4145: Cross-site Scripting (XSS) - Stored in pimcore/customer-data-framework
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository pimcore/customer-data-framework prior to 3.4.2.
Affected products
- pimcore/customer-data-framework: before 3.4.2 — fixed in 3.4.2
How to fix
Upgrade to a fixed version: pimcore/customer-data-framework 3.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/customer-data-framework/commit/72f45dd537a706954e7a71c99fbe318640e846a2
- https://huntr.dev/bounties/ce852777-2994-40b4-bb4e-c4d10023eeb0
- https://github.com/pimcore/customer-data-framework/commit/72f45dd537a706954e7a71c99fbe318640e846a2
- https://huntr.dev/bounties/ce852777-2994-40b4-bb4e-c4d10023eeb0
Get alerted when CVE-2023-4145 or the next vulnerability affects your stack