What’s Vulnerable › Vulnerabilities
CVE-2023-4148: Ditty < 3.1.25 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ditty WordPress plugin before 3.1.25 does not sanitise and escape some parameters and generated URLs before outputting them back in attributes, leading to Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Affected products
- Ditty: before 3.1.25 — fixed in 3.1.25
How to fix
Upgrade to a fixed version: Ditty 3.1.25. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/aa39de78-55b3-4237-84db-6fdf6820c58d
- https://wpscan.com/vulnerability/aa39de78-55b3-4237-84db-6fdf6820c58d
Get alerted when CVE-2023-4148 or the next vulnerability affects your stack