What’s Vulnerable › Vulnerabilities
CVE-2023-4158: Cross-site Scripting (XSS) - Stored in omeka/omeka-s
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository omeka/omeka-s prior to 4.0.3.
Affected products
- omeka/omeka-s: before 4.0.3 — fixed in 4.0.3
How to fix
Upgrade to a fixed version: omeka/omeka-s 4.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/omeka/omeka-s/commit/2a7fb26452167c8a1d95f207ae5328c6b1b0fcf8
- https://huntr.dev/bounties/e0e462ae-d7cb-4a84-b6fe-5f5de20e3d15
- https://github.com/omeka/omeka-s/commit/2a7fb26452167c8a1d95f207ae5328c6b1b0fcf8
- https://huntr.dev/bounties/e0e462ae-d7cb-4a84-b6fe-5f5de20e3d15
Get alerted when CVE-2023-4158 or the next vulnerability affects your stack