What’s Vulnerable › Vulnerabilities
CVE-2023-4162: Segmentation fault in Brocade Fabric OS after Brocade Fabric OS v9.0
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-31 · updated 2026-06-17
- Weakness: CWE-252
Description
A segmentation fault can occur in Brocade Fabric OS after Brocade Fabric OS v9.0 and before Brocade Fabric OS v9.2.0a through the passwdcfg command. This could allow an authenticated privileged user local user to crash a Brocade Fabric OS swith using the cli “passwdcfg --set -expire -minDiff“.
Affected products
- Brocade Fabric OS: from 9.0.1a before 9.2.0a — fixed in 9.2.0a
How to fix
Upgrade to a fixed version: Brocade Fabric OS 9.2.0a. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20231124-0010/
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/22513
- https://security.netapp.com/advisory/ntap-20231124-0010/
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/22513
Get alerted when CVE-2023-4162 or the next vulnerability affects your stack