What’s Vulnerable › Vulnerabilities
CVE-2023-4163: Possible buffer overflow in portcfgfportbuffers in Brocade Fabric OS
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-31 · updated 2026-06-17
- Weakness: CWE-120
Description
In Brocade Fabric OS before v9.2.0a, a local authenticated privileged user can trigger a buffer overflow condition, leading to a kernel panic with large input to buffers in the portcfgfportbuffers command.
Affected products
- Brocade Fabric OS: before 9.2.0a — fixed in 9.2.0a
How to fix
Upgrade to a fixed version: Brocade Fabric OS 9.2.0a. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20231130-0001/
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/22514
- https://security.netapp.com/advisory/ntap-20231130-0001/
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/22514
Get alerted when CVE-2023-4163 or the next vulnerability affects your stack