What’s Vulnerable › Vulnerabilities
CVE-2023-41677
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-10-22
- Weakness: CWE-522
Description
A insufficiently protected credentials vulnerability in Fortinet FortiOS 7.4.0 through 7.4.1, FortiOS 7.2.0 through 7.2.6, FortiOS 7.0.0 through 7.0.12, FortiOS 6.4.0 through 6.4.14, FortiOS 6.2.0 through 6.2.15, FortiOS 6.0 all versions, FortiProxy 7.4.0 through 7.4.1, FortiProxy 7.2.0 through 7.2.7, FortiProxy 7.0.0 through 7.0.13, FortiProxy 2.0 all versions, FortiProxy 01.02 all versions, FortiProxy 1.2 all versions, FortiProxy 01.01 all versions, FortiProxy 1.1 all versions, FortiProxy 01.00 all versions allows attacker to execute unauthorized code or commands via targeted social engineering attack
Affected products
- Fortinet FortiOS (FortiGate): from 6.0.0 before 6.2.16; from 6.4.0 before 6.4.15; from 7.0.0 before 7.0.13; from 7.2.0 before 7.2.7; from 7.4.0 before 7.4.2 — fixed in 6.2.16, 6.4.15, 7.0.13, 7.2.7, 7.4.2
- Fortinet FortiProxy: from 1.0.0 before 7.0.14; from 7.2.0 before 7.2.8; from 7.4.0 before 7.4.2 — fixed in 7.0.14, 7.2.8, 7.4.2
How to fix
Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 6.2.16, 6.4.15, 7.0.13, 7.2.7; Fortinet FortiProxy 7.0.14, 7.2.8, 7.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-41677 or the next vulnerability affects your stack