What’s Vulnerable › Vulnerabilities
CVE-2023-41835: Apache Struts: excessive disk usage
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-05 · updated 2026-06-17
- Weakness: CWE-459
Description
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied. Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which fixe this issue.
Affected products
- Apache Struts: from 2.0.0 before 2.5.32; from 6.1.2.1 before 6.3.0.1 — fixed in 2.5.32, 6.3.0.1
How to fix
Upgrade to a fixed version: Apache Struts 2.5.32, 6.3.0.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/6wj530kh3ono8phr642y9sqkl67ys2ft
- https://www.openwall.com/lists/oss-security/2023/12/09/1
- https://lists.apache.org/thread/6wj530kh3ono8phr642y9sqkl67ys2ft
- https://security.netapp.com/advisory/ntap-20231013-0001/
- https://www.openwall.com/lists/oss-security/2023/12/09/1
Get alerted when CVE-2023-41835 or the next vulnerability affects your stack