What’s Vulnerable › Vulnerabilities
CVE-2023-41878: Weak password of selenium VNC in MeterSphere
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-27 · updated 2026-06-17
- Weakness: CWE-798
Description
MeterSphere is a one-stop open source continuous testing platform, covering functions such as test tracking, interface testing, UI testing and performance testing. The Selenium VNC config used in Metersphere is using a weak password by default, attackers can login to vnc and obtain high permissions. This issue has been addressed in version 2.10.7 LTS. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- metersphere: before 2.10.7 — fixed in 2.10.7
How to fix
Upgrade to a fixed version: metersphere 2.10.7. Check the vendor advisory for mitigations.
References
- https://github.com/metersphere/installer/commit/02dd31c0951a225eaad99eda560e3eb91ba3001d
- https://github.com/metersphere/metersphere/security/advisories/GHSA-88vv-6rm4-59h9
- https://github.com/metersphere/installer/commit/02dd31c0951a225eaad99eda560e3eb91ba3001d
- https://github.com/metersphere/metersphere/security/advisories/GHSA-88vv-6rm4-59h9
Get alerted when CVE-2023-41878 or the next vulnerability affects your stack