What’s Vulnerable › Vulnerabilities
CVE-2023-4189: Cross-site Scripting (XSS) - Reflected in instantsoft/icms2
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in GitHub repository instantsoft/icms2 prior to 2.16.1-git.
Affected products
- InstantCMS: before 2.16.1 — fixed in 2.16.1
How to fix
Upgrade to a fixed version: InstantCMS 2.16.1. Check the vendor advisory for mitigations.
References
- https://github.com/instantsoft/icms2/commit/1dbc3e6c8fbf5d2dc551cb27fad0de3584dee40f
- https://huntr.dev/bounties/b00e6986-64e7-464e-ba44-e42476bfcdc4
- https://github.com/instantsoft/icms2/commit/1dbc3e6c8fbf5d2dc551cb27fad0de3584dee40f
- https://huntr.dev/bounties/b00e6986-64e7-464e-ba44-e42476bfcdc4
Get alerted when CVE-2023-4189 or the next vulnerability affects your stack