What’s Vulnerable › Vulnerabilities
CVE-2023-41890: Sustainsys.Saml2 Insufficient Identity Provider Issuer Validation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-19 · updated 2026-06-17
- Weakness: CWE-289
Description
Sustainsys.Saml2 library adds SAML2P support to ASP.NET web sites, allowing the web site to act as a SAML2 Service Provider. Prior to versions 1.0.3 and 2.9.2, when a response is processed, the issuer of the Identity Provider is not sufficiently validated. This could allow a malicious identity provider to craft a Saml2 response that is processed as if issued by another identity provider. It is also possible for a malicious end user to cause stored state intended for one identity provider to be used when processing the response from another provider. An application is impacted if they rely on any of these features in their authentication/authorization logic: the issuer of the generated identity and claims; or items in the stored request state (AuthenticationProperties). This issue is patched in versions 2.9.2 and 1.0.3. The `AcsCommandResultCreated` notification can be used to add the validation required if an upgrade to patched packages is not possible.
Affected products
- Sustainsys Saml2: before 1.0.3; from 2.0.0 before 2.9.2 — fixed in 1.0.3, 2.9.2
How to fix
Upgrade to a fixed version: Sustainsys Saml2 1.0.3, 2.9.2. Check the vendor advisory for mitigations.
References
- https://github.com/Sustainsys/Saml2/issues/712
- https://github.com/Sustainsys/Saml2/issues/713
- https://github.com/Sustainsys/Saml2/security/advisories/GHSA-fv2h-753j-9g39
- https://github.com/Sustainsys/Saml2/issues/712
- https://github.com/Sustainsys/Saml2/issues/713
- https://github.com/Sustainsys/Saml2/security/advisories/GHSA-fv2h-753j-9g39
Get alerted when CVE-2023-41890 or the next vulnerability affects your stack