What’s Vulnerable › Vulnerabilities
CVE-2023-41891: FlyteAdmin SQL Injection in List Filters
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-30 · updated 2026-06-17
- Weakness: CWE-89
Description
FlyteAdmin is the control plane for Flyte responsible for managing entities and administering workflow executions. Prior to version 1.1.124, list endpoints on FlyteAdmin have a SQL vulnerability where a malicious user can send a REST request with custom SQL statements as list filters. The attacker needs to have access to the FlyteAdmin installation, typically either behind a VPN or authentication. Version 1.1.124 contains a patch for this issue.
Affected products
- flyteorg flyteadmin: before 1.1.124 — fixed in 1.1.124
How to fix
Upgrade to a fixed version: flyteorg flyteadmin 1.1.124. Check the vendor advisory for mitigations.
References
- https://github.com/flyteorg/flyteadmin/commit/b3177ef70f068e908140b8a4a9913dfa74f289fd
- https://github.com/flyteorg/flyteadmin/security/advisories/GHSA-r847-6w6h-r8g4
- https://owasp.org/www-community/attacks/SQL_Injection#
- https://github.com/flyteorg/flyteadmin/commit/b3177ef70f068e908140b8a4a9913dfa74f289fd
- https://github.com/flyteorg/flyteadmin/security/advisories/GHSA-r847-6w6h-r8g4
- https://owasp.org/www-community/attacks/SQL_Injection#
Get alerted when CVE-2023-41891 or the next vulnerability affects your stack