What’s Vulnerable › Vulnerabilities
CVE-2023-41900: Jetty's OpenId Revoked authentication allows one request
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-15 · updated 2026-06-17
- Weakness: CWE-1390
Description
Jetty is a Java based web server and servlet engine. Versions 9.4.21 through 9.4.51, 10.0.15, and 11.0.15 are vulnerable to weak authentication. If a Jetty `OpenIdAuthenticator` uses the optional nested `LoginService`, and that `LoginService` decides to revoke an already authenticated user, then the current request will still treat the user as authenticated. The authentication is then cleared from the session and subsequent requests will not be treated as authenticated. So a request on a previously authenticated session could be allowed to bypass authentication after it had been rejected by the `LoginService`. This impacts usages of the jetty-openid which have configured a nested `LoginService` and where that `LoginService` will is capable of rejecting previously authenticated users. Versions 9.4.52, 10.0.16, and 11.0.16 have a patch for this issue.
Affected products
- Debian Linux: 11.0, 12.0
- The Eclipse Foundation Eclipse Jetty: from 9.4.21 before 9.4.52; from 10.0.0 before 10.0.16; from 11.0.0 before 11.0.16 — fixed in 10.0.16, 11.0.16, 9.4.52
How to fix
Upgrade to a fixed version: The Eclipse Foundation Eclipse Jetty 10.0.16, 11.0.16, 9.4.52. Check the vendor advisory for mitigations.
References
- https://github.com/eclipse/jetty.project/pull/9528
- https://github.com/eclipse/jetty.project/pull/9660
- https://github.com/eclipse/jetty.project/security/advisories/GHSA-pwh8-58vv-vw48
- https://security.netapp.com/advisory/ntap-20231110-0004/
- https://www.debian.org/security/2023/dsa-5507
- https://github.com/eclipse/jetty.project/pull/9528
- https://github.com/eclipse/jetty.project/pull/9660
- https://github.com/eclipse/jetty.project/security/advisories/GHSA-pwh8-58vv-vw48
- https://security.netapp.com/advisory/ntap-20231110-0004/
- https://www.debian.org/security/2023/dsa-5507
Get alerted when CVE-2023-41900 or the next vulnerability affects your stack