What’s Vulnerable › Vulnerabilities
CVE-2023-41902
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-20 · updated 2026-06-17
- Weakness: CWE-434
Description
An XPC misconfiguration vulnerability in CoreCode MacUpdater before 2.3.8, and 3.x before 3.1.2, allows attackers to escalate privileges by crafting malicious .pkg files.
Affected products
- Corecode Macupdater: before 2.3.8; from 3.0.0 before 3.1.2 — fixed in 2.3.8, 3.1.2
How to fix
Upgrade to a fixed version: Corecode Macupdater 2.3.8, 3.1.2. Check the vendor advisory for mitigations.
References
- https://gist.github.com/NSEcho/5d048a0796ceef59d6b1df1659bd1057
- https://www.corecode.io/macupdater/history2.html
- https://www.corecode.io/macupdater/history3.html
- https://gist.github.com/NSEcho/5d048a0796ceef59d6b1df1659bd1057
- https://www.corecode.io/macupdater/history2.html
- https://www.corecode.io/macupdater/history3.html
Get alerted when CVE-2023-41902 or the next vulnerability affects your stack