What’s Vulnerable › Vulnerabilities
CVE-2023-41910
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-05 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in lldpd before 1.0.17. By crafting a CDP PDU packet with specific CDP_TLV_ADDRESSES TLVs, a malicious actor can remotely force the lldpd daemon to perform an out-of-bounds read on heap memory. This occurs in cdp_decode in daemon/protocols/cdp.c.
Affected products
- lldpd: before 1.0.17 — fixed in 1.0.17
How to fix
Upgrade to a fixed version: lldpd 1.0.17. Check the vendor advisory for mitigations.
References
- https://github.com/lldpd/lldpd/commit/a9aeabdf879c25c584852a0bb5523837632f099b
- https://github.com/lldpd/lldpd/releases/tag/1.0.17
- https://lists.debian.org/debian-lts-announce/2023/09/msg00025.html
- https://www.debian.org/security/2023/dsa-5505
- https://github.com/lldpd/lldpd/commit/a9aeabdf879c25c584852a0bb5523837632f099b
- https://github.com/lldpd/lldpd/releases/tag/1.0.17
- https://lists.debian.org/debian-lts-announce/2023/09/msg00025.html
- https://www.debian.org/security/2023/dsa-5505
Get alerted when CVE-2023-41910 or the next vulnerability affects your stack