What’s Vulnerable › Vulnerabilities
CVE-2023-41913
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-07 · updated 2026-06-17
- Weakness: CWE-120
Description
strongSwan before 5.9.12 has a buffer overflow and possible unauthenticated remote code execution via a DH public value that exceeds the internal buffer in charon-tkm's DH proxy. The earliest affected version is 5.3.0. An attack can occur via a crafted IKE_SA_INIT message.
Affected products
- strongSwan: from 5.3.0 before 5.9.12 — fixed in 5.9.12
How to fix
Upgrade to a fixed version: strongSwan 5.9.12. Check the vendor advisory for mitigations.
References
- https://github.com/strongswan/strongswan/releases
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YPJZPYHBCRXUQGGKQE6TYH4J4RIJH6HO/
- https://www.strongswan.org/blog/2023/11/20/strongswan-vulnerability-%28cve-2023-41913%29.html
- https://github.com/strongswan/strongswan/releases
- https://lists.debian.org/debian-lts-announce/2023/11/msg00018.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YPJZPYHBCRXUQGGKQE6TYH4J4RIJH6HO/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YPJZPYHBCRXUQGGKQE6TYH4J4RIJH6HO/
- https://security.netapp.com/advisory/ntap-20250117-0003/
- https://www.strongswan.org/blog/2023/11/20/strongswan-vulnerability-%28cve-2023-41913%29.html
Get alerted when CVE-2023-41913 or the next vulnerability affects your stack