What’s Vulnerable › Vulnerabilities
CVE-2023-41916: Apache Linkis DataSource: DatasourceManager module has a JDBC parameter judgment logic vulnerability that allows for arbitrary file reading
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-15 · updated 2026-06-17
- Weakness: CWE-552
Description
In Apache Linkis =1.4.0, due to the lack of effective filtering of parameters, an attacker configuring malicious Mysql JDBC parameters in the DataSource Manager Module will trigger arbitrary file reading. Therefore, the parameters in the Mysql JDBC URL should be blacklisted. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out. Versions of Apache Linkis = 1.4.0 will be affected. We recommend users upgrade the version of Linkis to version 1.5.0.
Affected products
- Apache Software Foundation Apache Linkis: from 1.4.0 before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Linkis 1.6.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/dxkpwyoxy1jpdwlpqp15zvo0jxn4v729
- http://www.openwall.com/lists/oss-security/2024/07/13/4
- https://lists.apache.org/thread/dxkpwyoxy1jpdwlpqp15zvo0jxn4v729
Get alerted when CVE-2023-41916 or the next vulnerability affects your stack