What’s Vulnerable › Vulnerabilities
CVE-2023-4196: Cross-site Scripting (XSS) - Stored in cockpit-hq/cockpit
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository cockpit-hq/cockpit prior to 2.6.3.
Affected products
- cockpit-hq/cockpit: before 2.6.3 — fixed in 2.6.3
How to fix
Upgrade to a fixed version: cockpit-hq/cockpit 2.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/cockpit-hq/cockpit/commit/039a00cc310bff128ca6e6c1c46c6fbad0385c2c
- https://huntr.dev/bounties/c275a2d4-721f-49f7-8787-b146af2056a0
- https://github.com/cockpit-hq/cockpit/commit/039a00cc310bff128ca6e6c1c46c6fbad0385c2c
- https://huntr.dev/bounties/c275a2d4-721f-49f7-8787-b146af2056a0
Get alerted when CVE-2023-4196 or the next vulnerability affects your stack