What’s Vulnerable › Vulnerabilities
CVE-2023-4206: Use-after-free in Linux kernel's net/sched: cls_route component
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-06 · updated 2026-06-17
- Weakness: CWE-416
Description
A use-after-free vulnerability in the Linux kernel's net/sched: cls_route component can be exploited to achieve local privilege escalation. When route4_change() is called on an existing filter, the whole tcf_result struct is always copied into the new instance of the filter. This causes a problem when updating a filter bound to a class, as tcf_unbind_filter() is always called on the old instance in the success path, decreasing filter_cnt of the still referenced class and allowing it to be deleted, leading to a use-after-free. We recommend upgrading past commit b80b829e9e2c1b3f7aae34855e04d8f6ecaf13c8.
Affected products
- Debian Linux: 12.0
- Linux kernel: from 3.18 before 4.14.322; from 4.15 before 4.19.291; from 4.20 before 5.4.253; from 5.5 before 5.10.190; from 5.11 before 5.15.126; from 5.16 before 6.1.45 — fixed in 4.14.322, 4.19.291, 5.10.190, 5.15.126, 5.4.253, 6.1.45
How to fix
Upgrade to a fixed version: Linux kernel 4.14.322, 4.19.291, 5.10.190, 5.15.126. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=b80b829e9e2c1b3f7aae34855e04d8f6ecaf13c8
- https://kernel.dance/b80b829e9e2c1b3f7aae34855e04d8f6ecaf13c8
- https://lists.debian.org/debian-lts-announce/2024/01/msg00004.html
- https://www.debian.org/security/2023/dsa-5492
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=b80b829e9e2c1b3f7aae34855e04d8f6ecaf13c8
- https://kernel.dance/b80b829e9e2c1b3f7aae34855e04d8f6ecaf13c8
- https://lists.debian.org/debian-lts-announce/2024/01/msg00004.html
- https://www.debian.org/security/2023/dsa-5492
Get alerted when CVE-2023-4206 or the next vulnerability affects your stack