What’s Vulnerable › Vulnerabilities
CVE-2023-42115: Exim AUTH Out-Of-Bounds Write Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-787
Description
Exim AUTH Out-Of-Bounds Write Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Exim. Authentication is not required to exploit this vulnerability. The specific flaw exists within the smtp service, which listens on TCP port 25 by default. The issue results from the lack of proper validation of user-supplied data, which can result in a write past the end of a buffer. An attacker can leverage this vulnerability to execute code in the context of the service account. . Was ZDI-CAN-17434.
Affected products
- Exim: before 4.96.1 — fixed in 4.96.1
How to fix
Upgrade to a fixed version: Exim 4.96.1. Check the vendor advisory for mitigations.
References
- https://www.zerodayinitiative.com/advisories/ZDI-23-1469/
- https://www.zerodayinitiative.com/advisories/ZDI-23-1469/
Get alerted when CVE-2023-42115 or the next vulnerability affects your stack