What’s Vulnerable › Vulnerabilities
CVE-2023-42116: Exim SMTP Challenge Stack-based Buffer Overflow Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-121
Description
Exim SMTP Challenge Stack-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Exim. Authentication is not required to exploit this vulnerability. The specific flaw exists within the handling of NTLM challenge requests. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of the service account. . Was ZDI-CAN-17515.
Affected products
- Exim: before 4.96.1 — fixed in 4.96.1
How to fix
Upgrade to a fixed version: Exim 4.96.1. Check the vendor advisory for mitigations.
References
- https://www.zerodayinitiative.com/advisories/ZDI-23-1470/
- https://lists.debian.org/debian-lts-announce/2023/10/msg00002.html
- https://www.zerodayinitiative.com/advisories/ZDI-23-1470/
Get alerted when CVE-2023-42116 or the next vulnerability affects your stack