What’s Vulnerable › Vulnerabilities
CVE-2023-4214: AppPresser <= 4.2.5 - Insecure Password Reset Mechanism
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-18 · updated 2026-06-17
- Weakness: CWE-620
Description
The AppPresser plugin for WordPress is vulnerable to unauthorized password resets in versions up to, and including 4.2.5. This is due to the plugin generating too weak a reset code, and the code used to reset the password has no attempt or time limit.
Affected products
- scottopolis AppPresser – Mobile App Framework: before 4.3.0 — fixed in 4.3.0
How to fix
Upgrade to a fixed version: scottopolis AppPresser – Mobile App Framework 4.3.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/apppresser/trunk/inc/AppPresser_API_Limit.php?rev=2997182
- https://plugins.trac.wordpress.org/browser/apppresser/trunk/inc/AppPresser_WPAPI_Mods.php#L567
- https://plugins.trac.wordpress.org/changeset/2997160/apppresser
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4c44c36a-c4c7-49c2-b750-1589e7840dde?source=cve
- https://plugins.trac.wordpress.org/browser/apppresser/trunk/inc/AppPresser_API_Limit.php?rev=2997182
- https://plugins.trac.wordpress.org/browser/apppresser/trunk/inc/AppPresser_WPAPI_Mods.php#L567
- https://plugins.trac.wordpress.org/changeset/2997160/apppresser
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4c44c36a-c4c7-49c2-b750-1589e7840dde?source=cve
Get alerted when CVE-2023-4214 or the next vulnerability affects your stack