What’s Vulnerable › Vulnerabilities
CVE-2023-4218: XXE in eclipse.platform / Eclipse IDE
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-09 · updated 2026-06-17
- Weakness: CWE-611
Description
In Eclipse IDE versions < 2023-09 (4.29) some files with xml content are parsed vulnerable against all sorts of XXE attacks. The user just needs to open any evil project or update an open project with a vulnerable file (for example for review a foreign repository or patch).
Affected products
- Eclipse Foundation Eclipse IDE: before 4.29 — fixed in 4.29
- Eclipse Foundation org.eclipse.core.runtime: before 3.29.0 — fixed in 3.29.0
- eclipse Pde: before 3.13.2400 — fixed in 3.13.2400
How to fix
Upgrade to a fixed version: Eclipse Foundation Eclipse IDE 4.29; Eclipse Foundation org.eclipse.core.runtime 3.29.0; eclipse Pde 3.13.2400. Check the vendor advisory for mitigations.
References
- https://github.com/eclipse-cdt/cdt/commit/c7169b3186d2fef20f97467c3e2ad78e2943ed1b
- https://github.com/eclipse-emf/org.eclipse.emf/issues/10
- https://github.com/eclipse-jdt/eclipse.jdt.core/commit/38dd2a878f45cdb3d8d52090f1d6d1b532fd4c4d
- https://github.com/eclipse-jdt/eclipse.jdt.ui/commit/13675b1f8a74f47de4da89ed0ded6af7c21dfbec
- https://github.com/eclipse-pde/eclipse.pde/pull/632/
- https://github.com/eclipse-pde/eclipse.pde/pull/667/
- https://github.com/eclipse-platform/eclipse.platform.releng.buildtools/pull/45
- https://github.com/eclipse-platform/eclipse.platform.swt/commit/bf71db5ddcb967c0863dad4745367b54f49e06ba
- https://github.com/eclipse-platform/eclipse.platform.ui/commit/f243cf0a28785b89b7c50bf4e1cce48a917d89bd
- https://github.com/eclipse-platform/eclipse.platform/pull/761
- https://gitlab.eclipse.org/security/vulnerability-reports/-/issues/8
- https://github.com/eclipse-cdt/cdt/commit/c7169b3186d2fef20f97467c3e2ad78e2943ed1b
Get alerted when CVE-2023-4218 or the next vulnerability affects your stack