What’s Vulnerable › Vulnerabilities
CVE-2023-42276
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-08 · updated 2026-06-17
- Weakness: CWE-120
Description
hutool v5.8.21 was discovered to contain a buffer overflow via the component jsonArray.
Affected products
- Hutool: before 5.8.22 — fixed in 5.8.22
How to fix
Upgrade to a fixed version: Hutool 5.8.22. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-42276 or the next vulnerability affects your stack