What’s Vulnerable › Vulnerabilities
CVE-2023-4241: lol-html panics on certain HTML inputs
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-16 · updated 2026-06-17
- Weakness: CWE-20
Description
lol-html can cause panics on certain HTML inputs. Anyone processing arbitrary 3rd party HTML with the library is affected.
Affected products
- Cloudflare lol-html: before 1.1.1 — fixed in 1.1.1
How to fix
Upgrade to a fixed version: Cloudflare lol-html 1.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/cloudflare/lol-html/security/advisories/GHSA-c3x7-354f-4p2x
- https://github.com/cloudflare/lol-html/security/advisories/GHSA-c3x7-354f-4p2x
Get alerted when CVE-2023-4241 or the next vulnerability affects your stack