What’s Vulnerable › Vulnerabilities
CVE-2023-42431: Potential XSS on user preferences page
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-30 · updated 2026-06-17
- Weakness: CWE-20
Description
Cross-site Scripting (XSS) vulnerability in BlueSpiceAvatars extension of BlueSpice allows logged in user to inject arbitrary HTML into the profile image dialog on Special:Preferences. This only applies to the genuine user context.
Affected products
- Hallo Welt! GmbH BlueSpice: from 3.0 before 3.2.10.1; from 4.0 before 4.3.3 — fixed in 3.2.10.1, 4.3.3
How to fix
Upgrade to a fixed version: Hallo Welt! GmbH BlueSpice 3.2.10.1, 4.3.3. Check the vendor advisory for mitigations.
References
- https://en.wiki.bluespice.com/wiki/Security:Security_Advisories/BSSA-2023-02
- https://en.wiki.bluespice.com/wiki/Security:Security_Advisories/BSSA-2023-02
Get alerted when CVE-2023-42431 or the next vulnerability affects your stack