What’s Vulnerable › Vulnerabilities
CVE-2023-42446: Pow Mnesia cache doesn't invalidate all expired keys on startup
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-18 · updated 2026-06-17
- Weakness: CWE-298
Description
Pow is a authentication and user management solution for Phoenix and Plug-based apps. Starting in version 1.0.14 and prior to version 1.0.34, use of `Pow.Store.Backend.MnesiaCache` is susceptible to session hijacking as expired keys are not being invalidated correctly on startup. A session may expire when all `Pow.Store.Backend.MnesiaCache` instances have been shut down for a period that is longer than a session's remaining TTL. Version 1.0.34 contains a patch for this issue. As a workaround, expired keys, including all expired sessions, can be manually invalidated.
Affected products
- pow-auth pow: from 1.0.14 before 1.0.34 — fixed in 1.0.34
How to fix
Upgrade to a fixed version: pow-auth pow 1.0.34. Check the vendor advisory for mitigations.
References
- https://github.com/pow-auth/pow/issues/713
- https://github.com/pow-auth/pow/security/advisories/GHSA-3cjh-p6pw-jhv9
- https://github.com/pow-auth/pow/issues/713
- https://github.com/pow-auth/pow/security/advisories/GHSA-3cjh-p6pw-jhv9
Get alerted when CVE-2023-42446 or the next vulnerability affects your stack