What’s Vulnerable › Vulnerabilities
CVE-2023-42452: Mastodon vulnerable to Stored XSS through the translation feature
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Mastodon is a free, open-source social network server based on ActivityPub. In versions on the 4.x branch prior to versions 4.0.10, 4.2.8, and 4.2.0-rc2, under certain conditions, attackers can abuse the translation feature to bypass the server-side HTML sanitization, allowing unescaped HTML to execute in the browser. The impact is limited thanks to Mastodon's strict Content Security Policy, blocking inline scripts, etc. However a CSP bypass or loophole could be exploited to execute malicious XSS. Furthermore, it requires user interaction, as this can only occur upon clicking the “Translate” button on a malicious post. Versions 4.0.10, 4.2.8, and 4.2.0-rc2 contain a patch for this issue.
Affected products
- mastodon: from 4.0.0 before 4.0.10; from 4.1.0 before 4.1.8; 4.2.0-beta1, 4.2.0-beta2, 4.2.0-beta3, 4.2.0-rc1 — fixed in 4.0.10, 4.1.8
How to fix
Upgrade to a fixed version: mastodon 4.0.10, 4.1.8. Check the vendor advisory for mitigations.
References
- https://github.com/mastodon/mastodon/commit/ff32475f5f4a84ebf9619e7eef5bf8b4c075d0e2
- https://github.com/mastodon/mastodon/security/advisories/GHSA-2693-xr3m-jhqr
- https://github.com/mastodon/mastodon/commit/ff32475f5f4a84ebf9619e7eef5bf8b4c075d0e2
- https://github.com/mastodon/mastodon/security/advisories/GHSA-2693-xr3m-jhqr
Get alerted when CVE-2023-42452 or the next vulnerability affects your stack