What’s Vulnerable › Vulnerabilities
CVE-2023-42458: Zope vulnerable to Stored Cross Site Scripting with SVG images
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Zope is an open-source web application server. Prior to versions 4.8.10 and 5.8.5, there is a stored cross site scripting vulnerability for SVG images. Note that an image tag with an SVG image as source is never vulnerable, even when the SVG image contains malicious code. To exploit the vulnerability, an attacker would first need to upload an image, and then trick a user into following a specially crafted link. Patches are available in Zope 4.8.10 and 5.8.5. As a workaround, make sure the "Add Documents, Images, and Files" permission is only assigned to trusted roles. By default, only the Manager has this permission.
Affected products
- zopefoundation Zope: before 4.8.10; from 5.0.0 before 5.8.5 — fixed in 4.8.10, 5.8.5
How to fix
Upgrade to a fixed version: zopefoundation Zope 4.8.10, 5.8.5. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/09/22/2
- https://github.com/zopefoundation/Zope/commit/26a55dbc301db417f47cafda6fe0f983b5690088
- https://github.com/zopefoundation/Zope/commit/603b0a12881c90a072a7a65e32d47ed898ce37cb
- https://github.com/zopefoundation/Zope/security/advisories/GHSA-wm8q-9975-xh5v
- http://www.openwall.com/lists/oss-security/2023/09/22/2
- https://github.com/zopefoundation/Zope/commit/26a55dbc301db417f47cafda6fe0f983b5690088
- https://github.com/zopefoundation/Zope/commit/603b0a12881c90a072a7a65e32d47ed898ce37cb
- https://github.com/zopefoundation/Zope/security/advisories/GHSA-wm8q-9975-xh5v
Get alerted when CVE-2023-42458 or the next vulnerability affects your stack