What’s Vulnerable › Vulnerabilities
CVE-2023-42501: Apache Superset: Unnecessary read permissions within the Gamma role
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-27 · updated 2026-06-17
- Weakness: CWE-276
Description
Unnecessary read permissions within the Gamma role would allow authenticated users to read configured CSS templates and annotations. This issue affects Apache Superset: before 2.1.2. Users should upgrade to version or above 2.1.2 and run `superset init` to reconstruct the Gamma role or remove `can_read` permission from the mentioned resources.
Affected products
- Apache Superset: before 2.1.1 — fixed in 2.1.1
How to fix
Upgrade to a fixed version: Apache Superset 2.1.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/11/27/3
- https://lists.apache.org/thread/vk1rmrh9kz0chjmc9tk7o3md6zpz4ygh
- http://www.openwall.com/lists/oss-security/2023/11/27/3
- https://lists.apache.org/thread/vk1rmrh9kz0chjmc9tk7o3md6zpz4ygh
Get alerted when CVE-2023-42501 or the next vulnerability affects your stack