What’s Vulnerable › Vulnerabilities
CVE-2023-42502: Apache Superset: Open Redirect Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-28 · updated 2026-06-17
- Weakness: CWE-601
Description
An authenticated attacker with update datasets permission could change a dataset link to an untrusted site by spoofing the HTTP Host header, users could be redirected to this site when clicking on that specific dataset. This issue affects Apache Superset versions before 3.0.0.
Affected products
- Apache Superset: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: Apache Superset 3.0.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/n8348f194d8o8mln3oxd0s8jdl5bxbmn
- https://lists.apache.org/thread/n8348f194d8o8mln3oxd0s8jdl5bxbmn
Get alerted when CVE-2023-42502 or the next vulnerability affects your stack