What’s Vulnerable › Vulnerabilities
CVE-2023-42504: Apache Superset: Lack of rate limiting allows for possible denial of service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-28 · updated 2026-06-17
- Weakness: CWE-770
Description
An authenticated malicious user could initiate multiple concurrent requests, each requesting multiple dashboard exports, leading to a possible denial of service. This issue affects Apache Superset: before 3.0.0
Affected products
- Apache Superset: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: Apache Superset 3.0.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/11/28/6
- https://lists.apache.org/thread/yzq5gk1y9lyw6nxwd3xdkxg1djqw1h6l
- http://www.openwall.com/lists/oss-security/2023/11/28/6
- https://lists.apache.org/thread/yzq5gk1y9lyw6nxwd3xdkxg1djqw1h6l
Get alerted when CVE-2023-42504 or the next vulnerability affects your stack