What’s Vulnerable › Vulnerabilities
CVE-2023-42505: Apache Superset: Sensitive information disclosure on db connection details
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-28 · updated 2026-06-17
- Weakness: CWE-200
Description
An authenticated user with read permissions on database connections metadata could potentially access sensitive information such as the connection's username. This issue affects Apache Superset before 3.0.0.
Affected products
- Apache Superset: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: Apache Superset 3.0.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/11/28/5
- https://lists.apache.org/thread/bd0fhtfzrtgo1q8x35tpm8ms144d1t2y
- http://www.openwall.com/lists/oss-security/2023/11/28/5
- https://lists.apache.org/thread/bd0fhtfzrtgo1q8x35tpm8ms144d1t2y
Get alerted when CVE-2023-42505 or the next vulnerability affects your stack