What’s Vulnerable › Vulnerabilities
CVE-2023-42780: Apache Airflow: Improper access control vulnerability in the "List dag warnings" feature
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-14 · updated 2026-06-17
- Weakness: CWE-200
Description
Apache Airflow, versions prior to 2.7.2, contains a security vulnerability that allows authenticated users of Airflow to list warnings for all DAGs, even if the user had no permission to see those DAGs. It would reveal the dag_ids and the stack-traces of import errors for those DAGs with import errors. Users of Apache Airflow are advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.
Affected products
- Apache Airflow: before 2.7.2 — fixed in 2.7.2
How to fix
Upgrade to a fixed version: Apache Airflow 2.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/34355
- https://lists.apache.org/thread/h5tvsvov8j55wojt5sojdprs05oby34d
- https://github.com/apache/airflow/pull/34355
- https://lists.apache.org/thread/h5tvsvov8j55wojt5sojdprs05oby34d
Get alerted when CVE-2023-42780 or the next vulnerability affects your stack