What’s Vulnerable › Vulnerabilities
CVE-2023-42781: Apache Airflow: Permission verification bypass allows viewing dagruns of other dags
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-12 · updated 2026-06-17
- Weakness: CWE-200
Description
Apache Airflow, versions before 2.7.3, has a vulnerability that allows an authorized user who has access to read specific DAGs only, to read information about task instances in other DAGs. This is a different issue than CVE-2023-42663 but leading to similar outcome. Users of Apache Airflow are advised to upgrade to version 2.7.3 or newer to mitigate the risk associated with this vulnerability.
Affected products
- Apache Airflow: before 2.7.3 — fixed in 2.7.3
How to fix
Upgrade to a fixed version: Apache Airflow 2.7.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/11/12/2
- https://github.com/apache/airflow/pull/34939
- https://lists.apache.org/thread/7dnl8nszdxqyns57f3dw0sloy5dfl9o1
- http://www.openwall.com/lists/oss-security/2023/11/12/2
- https://github.com/apache/airflow/pull/34939
- https://lists.apache.org/thread/7dnl8nszdxqyns57f3dw0sloy5dfl9o1
Get alerted when CVE-2023-42781 or the next vulnerability affects your stack