What’s Vulnerable › Vulnerabilities
CVE-2023-42802: GLPI vulnerable to unallowed PHP script execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-02 · updated 2026-06-17
- Weakness: CWE-20
Description
GLPI is a free asset and IT management software package. Starting in version 10.0.7 and prior to version 10.0.10, an unverified object instantiation allows one to upload malicious PHP files to unwanted directories. Depending on web server configuration and available system libraries, malicious PHP files can then be executed through a web server request. Version 10.0.10 fixes this issue. As a workaround, remove write access on `/ajax` and `/front` files to the web server.
Affected products
- glpi-project glpi: from 10.0.7 before 10.0.10 — fixed in 10.0.10
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.10. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/releases/tag/10.0.10
- https://github.com/glpi-project/glpi/security/advisories/GHSA-rrh2-x4ch-pq3m
- https://github.com/glpi-project/glpi/releases/tag/10.0.10
- https://github.com/glpi-project/glpi/security/advisories/GHSA-rrh2-x4ch-pq3m
Get alerted when CVE-2023-42802 or the next vulnerability affects your stack