What’s Vulnerable › Vulnerabilities
CVE-2023-42810: systeminformation SSID Command Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-21 · updated 2026-06-17
- Weakness: CWE-77
Description
systeminformation is a System Information Library for Node.JS. Versions 5.0.0 through 5.21.6 have a SSID Command Injection Vulnerability. The problem was fixed with a parameter check in version 5.21.7. As a workaround, check or sanitize parameter strings that are passed to `wifiConnections()`, `wifiNetworks()` (string only).
Affected products
- sebhildebrandt systeminformation: from 5.0.0 before 5.21.7 — fixed in 5.21.7
How to fix
Upgrade to a fixed version: sebhildebrandt systeminformation 5.21.7. Check the vendor advisory for mitigations.
References
- https://github.com/sebhildebrandt/systeminformation/commit/7972565812ccb2a610a22911c54c3446f4171392
- https://github.com/sebhildebrandt/systeminformation/security/advisories/GHSA-gx6r-qc2v-3p3v
- https://systeminformation.io/security.html
- https://github.com/sebhildebrandt/systeminformation/commit/7972565812ccb2a610a22911c54c3446f4171392
- https://github.com/sebhildebrandt/systeminformation/security/advisories/GHSA-gx6r-qc2v-3p3v
- https://systeminformation.io/security.html
Get alerted when CVE-2023-42810 or the next vulnerability affects your stack