What’s Vulnerable › Vulnerabilities
CVE-2023-42812: Galaxy vulnerable to Server Side Request Forgery during data imports
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-22 · updated 2026-06-17
- Weakness: CWE-918
Description
Galaxy is an open-source platform for FAIR data analysis. Prior to version 22.05, Galaxy is vulnerable to server-side request forgery, which allows a malicious to issue arbitrary HTTP/HTTPS requests from the application server to internal hosts and read their responses. Version 22.05 contains a patch for this issue.
Affected products
- galaxyproject galaxy: before 22.05 — fixed in 22.05
How to fix
Upgrade to a fixed version: galaxyproject galaxy 22.05. Check the vendor advisory for mitigations.
References
- https://github.com/galaxyproject/galaxy/blob/06d56c859713b74f1c2e35da1c2fcbbf0a965645/lib/galaxy/files/uris.py
- https://github.com/galaxyproject/galaxy/security/advisories/GHSA-vf5q-r8p9-35xh
- https://github.com/galaxyproject/galaxy/blob/06d56c859713b74f1c2e35da1c2fcbbf0a965645/lib/galaxy/files/uris.py
- https://github.com/galaxyproject/galaxy/security/advisories/GHSA-vf5q-r8p9-35xh
Get alerted when CVE-2023-42812 or the next vulnerability affects your stack