What’s Vulnerable › Vulnerabilities
CVE-2023-42817: Cross-site Scripting (XSS) in pimcore admin-ui-classic-bundle translations
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-25 · updated 2026-06-17
- Weakness: CWE-79
Description
Pimcore admin-ui-classic-bundle provides a Backend UI for Pimcore. The translation value with text including “%s” (from “%suggest%) is parsed by sprintf() even though it’s supposed to be output literally to the user. The translations may be accessible by a user with comparatively lower overall access (as the translation permission cannot be scoped to certain “modules”) and a skilled attacker might be able to exploit the parsing of the translation string in the dialog box. This issue has been patched in commit `abd77392` which is included in release 1.1.2. Users are advised to update to version 1.1.2 or apply the patch manually.
Affected products
- pimcore admin-ui-classic-bundle: before 1.1.2 — fixed in 1.1.2
How to fix
Upgrade to a fixed version: pimcore admin-ui-classic-bundle 1.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/admin-ui-classic-bundle/commit/abd7739298f974319e3cac3fd4fcd7f995b63e4c
- https://github.com/pimcore/admin-ui-classic-bundle/security/advisories/GHSA-m988-7375-7g2c
- https://github.com/pimcore/admin-ui-classic-bundle/commit/abd7739298f974319e3cac3fd4fcd7f995b63e4c
- https://github.com/pimcore/admin-ui-classic-bundle/security/advisories/GHSA-m988-7375-7g2c
Get alerted when CVE-2023-42817 or the next vulnerability affects your stack