What’s Vulnerable › Vulnerabilities
CVE-2023-42819: Path traversal in Jumpserver
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-27 · updated 2026-06-17
- Weakness: CWE-22
Description
JumpServer is an open source bastion host. Logged-in users can access and modify the contents of any file on the system. A user can use the 'Job-Template' menu and create a playbook named 'test'. Get the playbook id from the detail page, like 'e0adabef-c38f-492d-bd92-832bacc3df5f'. An attacker can exploit the directory traversal flaw using the provided URL to access and retrieve the contents of the file. `https://jumpserver-ip/api/v1/ops/playbook/e0adabef-c38f-492d-bd92-832bacc3df5f/file/?key=../../../../../../../etc/passwd` a similar method to modify the file content is also present. This issue has been addressed in version 3.6.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- jumpserver: from 3.0.0 before 3.6.5 — fixed in 3.6.5
How to fix
Upgrade to a fixed version: jumpserver 3.6.5. Check the vendor advisory for mitigations.
References
- https://github.com/jumpserver/jumpserver/commit/d0321a74f1713d031560341c8fd0a1859e6510d8
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-ghg2-2whp-6m33
- https://github.com/jumpserver/jumpserver/commit/d0321a74f1713d031560341c8fd0a1859e6510d8
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-ghg2-2whp-6m33
Get alerted when CVE-2023-42819 or the next vulnerability affects your stack