What’s Vulnerable › Vulnerabilities
CVE-2023-42820: Random seed leakage in Jumpserver
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-27 · updated 2026-06-17
- Weakness: CWE-200
Description
JumpServer is an open source bastion host. This vulnerability is due to exposing the random number seed to the API, potentially allowing the randomly generated verification codes to be replayed, which could lead to password resets. If MFA is enabled users are not affect. Users not using local authentication are also not affected. Users are advised to upgrade to either version 2.28.19 or to 3.6.5. There are no known workarounds or this issue.
Affected products
- jumpserver: from 2.24.0 before 2.28.19; from 3.0.0 before 3.6.5 — fixed in 2.28.19, 3.6.5
How to fix
Upgrade to a fixed version: jumpserver 2.28.19, 3.6.5. Check the vendor advisory for mitigations.
References
- https://github.com/jumpserver/jumpserver/commit/42337f0d00b2a8d45ef063eb5b7deeef81597da5
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-7prv-g565-82qp
- https://github.com/jumpserver/jumpserver/commit/42337f0d00b2a8d45ef063eb5b7deeef81597da5
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-7prv-g565-82qp
Get alerted when CVE-2023-42820 or the next vulnerability affects your stack