What’s Vulnerable › Vulnerabilities
CVE-2023-4284: Post Timeline < 2.2.6 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-04 · updated 2026-06-17
Description
The Post Timeline WordPress plugin before 2.2.6 does not sanitise and escape an invalid nonce before outputting it back in an AJAX response, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- Post Timeline: before 2.2.6 — fixed in 2.2.6
How to fix
Upgrade to a fixed version: Post Timeline 2.2.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1c126869-0afa-456f-94cc-10334964e5f9
- https://wpscan.com/vulnerability/1c126869-0afa-456f-94cc-10334964e5f9
- https://wpscan.com/vulnerability/1c126869-0afa-456f-94cc-10334964e5f9
Get alerted when CVE-2023-4284 or the next vulnerability affects your stack