What’s Vulnerable › Vulnerabilities
CVE-2023-42852
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-25 · updated 2026-06-17
Description
A logic issue was addressed with improved checks. This issue is fixed in iOS 17.1 and iPadOS 17.1, watchOS 10.1, iOS 16.7.2 and iPadOS 16.7.2, macOS Sonoma 14.1, Safari 17.1, tvOS 17.1. Processing web content may lead to arbitrary code execution.
Affected products
- Apple iPadOS: before 16.7.2; from 17.0 before 17.1 — fixed in 16.7.2, 17.1
- Apple Iphone Os: before 16.7.2; from 17.0 before 17.1 — fixed in 16.7.2, 17.1
- Apple macOS: from 14.0 before 14.1 — fixed in 14.1
- Apple Safari: before 17.1 — fixed in 17.1
- Apple tvOS: before 17.1 — fixed in 17.1
- Apple watchOS: before 10.1 — fixed in 10.1
- Debian Linux: 11.0, 12.0
- Fedoraproject Fedora: 37
How to fix
Upgrade to a fixed version: Apple iPadOS 16.7.2, 17.1; Apple Iphone Os 16.7.2, 17.1; Apple macOS 14.1; Apple Safari 17.1; Apple tvOS 17.1; Apple watchOS 10.1. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2023/Oct/19
- http://seclists.org/fulldisclosure/2023/Oct/22
- http://seclists.org/fulldisclosure/2023/Oct/23
- http://seclists.org/fulldisclosure/2023/Oct/24
- http://seclists.org/fulldisclosure/2023/Oct/25
- http://seclists.org/fulldisclosure/2023/Oct/27
- http://www.openwall.com/lists/oss-security/2023/11/15/1
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RPPMOWFYZODONTA3RLZOKSGNR4DELGG2/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/S3O7ITSBZDHLBM5OG22K6RZAHRRTGECM/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZTCZGQPRDAOPP6NK4CIDJKIPMBWD5J7K/
- https://security.gentoo.org/glsa/202401-33
- https://support.apple.com/en-us/HT213981
Get alerted when CVE-2023-42852 or the next vulnerability affects your stack