What’s Vulnerable › Vulnerabilities
CVE-2023-4294: URL Shortify < 1.7.6 - Unauthenticated Stored XSS via referer header
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-11 · updated 2026-06-17
Description
The URL Shortify WordPress plugin before 1.7.6 does not properly escape the value of the referer header, thus allowing an unauthenticated attacker to inject malicious javascript that will trigger in the plugins admin panel with statistics of the created short link.
Affected products
- URL Shortify: before 1.7.6 — fixed in 1.7.6
How to fix
Upgrade to a fixed version: URL Shortify 1.7.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1fc71fc7-861a-46cc-a147-1c7ece9a7776
- https://wpscan.com/vulnerability/1fc71fc7-861a-46cc-a147-1c7ece9a7776
Get alerted when CVE-2023-4294 or the next vulnerability affects your stack