What’s Vulnerable › Vulnerabilities
CVE-2023-4300: Import XML and RSS Feeds < 2.1.4 - Admin+ Arbitrary File Upload
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-25 · updated 2026-06-17
Description
The Import XML and RSS Feeds WordPress plugin before 2.1.4 does not filter file extensions for uploaded files, allowing an attacker to upload a malicious PHP file, leading to Remote Code Execution.
Affected products
- Import XML and RSS Feeds: before 2.1.4 — fixed in 2.1.4
How to fix
Upgrade to a fixed version: Import XML and RSS Feeds 2.1.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d4220025-2272-4d5f-9703-4b2ac4a51c42
- https://wpscan.com/vulnerability/d4220025-2272-4d5f-9703-4b2ac4a51c42
Get alerted when CVE-2023-4300 or the next vulnerability affects your stack