What’s Vulnerable › Vulnerabilities
CVE-2023-43091: Gnome-maps: gnome maps is vulnerable to a code injection attack (similar to xss) via its service.json
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-17 · updated 2026-06-17
- Weakness: CWE-79
Description
A flaw was found in GNOME Maps, which is vulnerable to a code injection attack via its service.json configuration file. If the configuration file is malicious, it may execute arbitrary code.
Affected products
- Gnome-Maps: from 43.0 before 43.7; from 44.0 before 44.4 — fixed in 43.7, 44.4
How to fix
Upgrade to a fixed version: Gnome-Maps 43.7, 44.4. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2239091
- https://gitlab.gnome.org/GNOME/gnome-maps/-/commit/d26cd774d524404ef7784e6808f551de83de4bea
- https://gitlab.gnome.org/GNOME/gnome-maps/-/issues/588
Get alerted when CVE-2023-43091 or the next vulnerability affects your stack