What’s Vulnerable › Vulnerabilities
CVE-2023-43114
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-18 · updated 2026-06-17
Description
An issue was discovered in Qt before 5.15.16, 6.x before 6.2.10, and 6.3.x through 6.5.x before 6.5.3 on Windows. When using the GDI font engine, if a corrupted font is loaded via QFontDatabase::addApplicationFont{FromData], then it can cause the application to crash because of missing length checks.
Affected products
- Qt: before 5.15.16; from 6.0.0 before 6.2.10; from 6.5.0 before 6.5.3 — fixed in 5.15.16, 6.2.10, 6.5.3
How to fix
Upgrade to a fixed version: Qt 5.15.16, 6.2.10, 6.5.3. Check the vendor advisory for mitigations.
References
- https://codereview.qt-project.org/c/qt/qtbase/+/503026
- https://codereview.qt-project.org/c/qt/qtbase/+/503026
Get alerted when CVE-2023-43114 or the next vulnerability affects your stack