What’s Vulnerable › Vulnerabilities

CVE-2023-4317: Incorrect Authorization in GitLab

Description

An issue has been discovered in GitLab affecting all versions starting from 9.2 before 16.4.3, all versions starting from 16.5 before 16.5.3, all versions starting from 16.6 before 16.6.1. It was possible for a user with the Developer role to update a pipeline schedule from an unprotected branch to a protected branch.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.4.3, 16.5.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-4317 or the next vulnerability affects your stack