What’s Vulnerable › Vulnerabilities
CVE-2023-43208: NextGen Healthcare Mirth Connect Deserialization of Untrusted Data Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2024-05-20
- EPSS: 85.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-26 · updated 2026-06-17
- Weakness: CWE-78
Description
NextGen Healthcare Mirth Connect before version 4.4.1 is vulnerable to unauthenticated remote code execution. Note that this vulnerability is caused by the incomplete patch of CVE-2023-37679.
Affected products
- Nextgen Mirth Connect: before 4.4.1 — fixed in 4.4.1
How to fix
Upgrade to a fixed version: Nextgen Mirth Connect 4.4.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/176920/Mirth-Connect-4.4.0-Remote-Command-Execution.html
- https://www.horizon3.ai/nextgen-mirth-connect-remote-code-execution-vulnerability-cve-2023-43208/
- http://packetstormsecurity.com/files/176920/Mirth-Connect-4.4.0-Remote-Command-Execution.html
- https://www.horizon3.ai/nextgen-mirth-connect-remote-code-execution-vulnerability-cve-2023-43208/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-43208
Get alerted when CVE-2023-43208 or the next vulnerability affects your stack