What’s Vulnerable › Vulnerabilities
CVE-2023-4321: Cross-site Scripting (XSS) - Stored in cockpit-hq/cockpit
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository cockpit-hq/cockpit prior to 2.4.3.
Affected products
- cockpit-hq/cockpit: before 2.4.3 — fixed in 2.4.3
How to fix
Upgrade to a fixed version: cockpit-hq/cockpit 2.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/cockpit-hq/cockpit/commit/34ab31ee9362da51b9709e178469dbffd7717249
- https://huntr.dev/bounties/fce38751-bfd6-484c-b6e1-935e0aa8ffdc
- https://github.com/cockpit-hq/cockpit/commit/34ab31ee9362da51b9709e178469dbffd7717249
- https://huntr.dev/bounties/fce38751-bfd6-484c-b6e1-935e0aa8ffdc
Get alerted when CVE-2023-4321 or the next vulnerability affects your stack